omc seadrive 1.6 ltr 2 yr old power head suddenly running poorly

Discussion in 'Outboards' started by 3 boat guy, Aug 11, 2010.

  1. 3 boat guy
    Joined: Jun 2010
    Posts: 3
    Likes: 0, Points: 0, Legacy Rep: 10
    Location: li ny

    3 boat guy New Member

    checked the fuel supply for water, changed the fuel filter anyway, new plugs, new wires still runs only at high idle with heavy choking. This is a 1.6 looper,just put it in the water drove great on the way to dock space stalled and restarted a couple of times dosent run right, all input welcome
     
  2. powerabout
    Joined: Nov 2007
    Posts: 2,937
    Likes: 66, Points: 48, Legacy Rep: 719
    Location: Melbourne/Singapore/Italy

    powerabout Senior Member

    1.6 is a crossflow
    1.8 or 2.0 is a looper

    which do you have
     
  3. kenJ
    Joined: Jul 2005
    Posts: 349
    Likes: 5, Points: 0, Legacy Rep: 56
    Location: Williamsburg, VA

    kenJ Senior Member

    If it has a carb(s) suspect they need a rebuild. They fact it only runs with the choke on would seem to indicate a lack of fuel. If injectors, might want to run a concentrated mixture of fuel/injector cleaner thru the engine, make a temp connection from a portable fuel can to the fuel pump.
     
Forum posts represent the experience, opinion, and view of individual users. Boat Design Net does not necessarily endorse nor share the view of each individual post.
When making potentially dangerous or financial decisions, always employ and consult appropriate professionals. Your circumstances or experience may be different.