Mcck spec E won't stay running

Discussion in 'OnBoard Electronics & Controls' started by Tom Blizzard, Mar 17, 2020.

  1. Tom Blizzard
    Joined: Mar 2020
    Posts: 2
    Likes: 0, Points: 1
    Location: Tennessee

    Tom Blizzard New Member

    I have a very old 6500 MCCK spec E. The troubleshooting I've done seems to point to something going wrong with a 12-volt side. I can start it and run it and measure the low and high charging currents both at about 14 Volts for about 45 seconds. Then the DC voltage drops to zero and of course the generator stops running.
     
  2. gonzo
    Joined: Aug 2002
    Posts: 14,137
    Likes: 539, Points: 123, Legacy Rep: 2031
    Location: Milwaukee, WI

    gonzo Senior Member

    OK, so the problem is with the engine part if it won't run longer than 45 seconds. Does the power to the ignition go to zero when the engine stops?
     
  3. Tom Blizzard
    Joined: Mar 2020
    Posts: 2
    Likes: 0, Points: 1
    Location: Tennessee

    Tom Blizzard New Member

    This is a spec e Genset with solid state control. Power to the ignition goes to zero because the solid state control is telling it to shut down. It's telling it to shut down because it's no longer getting the correct high and low charge current from the generator itself. I can force it to run by pressing the Rope start switch which ignores the inputs from the generator and just supplies 12 volts from the battery to the ignition. I feel like the large wirewound resistor it's getting hot and failing but I could be wrong
     
Loading...
Forum posts represent the experience, opinion, and view of individual users. Boat Design Net does not necessarily endorse nor share the view of each individual post.
When making potentially dangerous or financial decisions, always employ and consult appropriate professionals. Your circumstances or experience may be different.