1986 Four winns 190 horizon lights

Discussion in 'OnBoard Electronics & Controls' started by coolmethirteen, Jun 26, 2010.

  1. coolmethirteen
    Joined: Jun 2010
    Posts: 5
    Likes: 0, Points: 0, Legacy Rep: 10
    Location: mich

    coolmethirteen Junior Member

    I have a 1986. Four winns 190 horizon. The problem is that once ithe motor is running. I cut on the lights and the motor and everything shuts down. Also the the mph, temp and some of the other meters don't work. If someone can help me I appriciate it. Thanks.
     
  2. Tim B
    Joined: Jan 2003
    Posts: 1,438
    Likes: 59, Points: 0, Legacy Rep: 841
    Location: Southern England

    Tim B Senior Member

    Sounds like there is at least one short circuit. Trace the system with a multimeter and replace any bad wiring or connections.

    Your gauges may not work due to a short to ground, or due to corroded plugs/connections.

    Tim B.
     
  3. Bglad
    Joined: May 2010
    Posts: 175
    Likes: 5, Points: 18, Legacy Rep: 67
    Location: Jacksonville, Florida

    Bglad Senior Member

    This happened to a friend of mine with a ski boat. In his case the gauges and switches fed from the engine harness. There was a bad connection or wire in the battery positive coming up to the panel from the engine. Due to the poor connection it could carry very little current. Turn anything on while the engine was running and in effect you would ground out the ignition and shut the engine down. If your wiring is configured the same way you need to be looking for loose connections, bad pin connector, bad ignition switch or broken wire(s) somewhere in the engine harness.
     
Loading...
Forum posts represent the experience, opinion, and view of individual users. Boat Design Net does not necessarily endorse nor share the view of each individual post.
When making potentially dangerous or financial decisions, always employ and consult appropriate professionals. Your circumstances or experience may be different.