1975 Mercruiser 302 Ford - 225S

Discussion in 'Sterndrives' started by Jaytan, Jul 28, 2018.

  1. Jaytan
    Joined: Jul 2018
    Posts: 3
    Likes: 0, Points: 1
    Location: Kelowna, BC. CANADA

    Jaytan New Member

    I have had this boat, an 18' Glastron since new. It has a fresh water cooling system which I religiously drain every fall for the winter. Then in the Spring when putting it into the water it always heats-up so I would shut the engine off for a few minutes, then start it up again to see if the temperature guage would come back to normal. If it did it would be fine for the season, if not I would repeat the process again until the heat guage would stay at normal. This was a yearly process.
    Over the years I've replaced the lower leg pick-up pump impellor, waterpump, thermostat, checked and cleaned the exhaust manifolds etc., and every year at start-up it always does the same thing. At Spring start-ups with muffs on I've tried warming it up for 4/5 minutes, pulling out the brass manifold plugs, starting the engine until water comes out of the the manifold plug holes, putting the plugs back in and wait for maybe 45 minutes - this sometimes worked and other times did not.
    After 43 years and this mystery every year I'd sure like to know what the issue is.
    Are there any fine gentleman out there that may have some solutions ?
    Regards,
    Jaytan
     
  2. gonzo
    Joined: Aug 2002
    Posts: 13,775
    Likes: 434, Points: 93, Legacy Rep: 2031
    Location: Milwaukee, WI

    gonzo Senior Member

    What engine and model does it have?
     
  3. powerabout
    Joined: Nov 2007
    Posts: 2,903
    Likes: 61, Points: 48, Legacy Rep: 719
    Location: Melbourne/Singapore/Italy

    powerabout Senior Member

    How about a photo as the Merc kit on a 225 included the manifolds in the freshwater so I would like to see what you are removing and get raw water flow?
     
  4. Jaytan
    Joined: Jul 2018
    Posts: 3
    Likes: 0, Points: 1
    Location: Kelowna, BC. CANADA

    Jaytan New Member

    Jaytan - Am attempting to send pictures of my water manifold as requested, two (2) of them - looks like I have to send them separately, maybe I'm wrong but will try anyway.
    Regards,
    Jaytan
     

    Attached Files:


  5. Jaytan
    Joined: Jul 2018
    Posts: 3
    Likes: 0, Points: 1
    Location: Kelowna, BC. CANADA

    Jaytan New Member

    Jaytan - this is the second of two (2) pictures I'm sending and hope you receive them in answer to your request for pictures of the manifold assembly.
    Please don't tell me I have been taking out the wrong manifold water plugs for 43 years. The ones I have been taking out are the 3/8" 24 TPI Brass plugs and not the larger square socket Cast Iron plugs.
    Regards,
    Jaytan
     

    Attached Files:

Loading...
Forum posts represent the experience, opinion, and view of individual users. Boat Design Net does not necessarily endorse nor share the view of each individual post.
When making potentially dangerous or financial decisions, always employ and consult appropriate professionals. Your circumstances or experience may be different.