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DELFTship tutorial – Using background images
Description
By using scanned images of an existing linesplan it is shown how a 3D DELFTship model can be created
using background images. The linesplan used for this tutorial is from an old motorboat. It's a hard chined
motorboat with slightly curved sides at the stern.
During this tutorial also a lot of the basics will be
explained. You'll be shown how to
• Create knuckle lines
• Use background images
• Assign control curves
• Fair control curves by moving points with the

mouse
• Move points with the cursor keys.

Illustration 1: Linesplan used for this tutorial

• Add new faces manually
• Insert new points
• Insert new edges
• Add new layers
• Select faces
• Assign faces to a different layer
• Add stations
• Make a curved transom that ends perpendicular to the centerplane of the hull

1. Start a new model
Description
Start a new model

Action
Select File => New from the
mainmenu

The window from illustration 2
appears. Fill in the appropriate
numbers.

Illustration 2: New model window.
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2. Creating knuckle lines
Description

Action

The default hull is a round
bottomed sailing boat. The
linesplan we're trying to
reproduce is a hard chined
motorboat. The first thing we're
going to do is create a knuckle
line that is going to be the
chine of our motorboat

Select the edges as shown in image 3.
You can select them one by one by
clicking on each edge with the left
mouse button. An easier and faster
way is to select just one edge while
keeping the Ctrl key on your keyboard
pressed. DELFTship automatically
traces and selects the connected
edges.

Turn the normal edges into
knuckle (crease) edges.
DELFTship draws crease
edges in red.

Select Edit => Edge => Crease from
the mainmenu.

Illustration 3: Creating a knuckle line.

3. Inserting background images
Description

Action

DELFTship has three different Select the window showing the profile
views on your model
view. If no such window is available
select a random one and set the view
•
Plan (top) view
to profile view. This is done by
•
Profile (side) view
pressing the right mouse button
somewhere in the window area. A pop•
Bodyplan (front)
up menu appears. Select View =>
view
Profile.
•
Perspective (view). Call the pop-up menu again and select
You can assign a different
background image to each of
these vies, except for the
perspective view

Background image => Load. This
opens the file browser. Select the file
you want to use for a background
image.

4. Moving a background image
Description

Action

The background image is now
inserted into your model. Every
time you select the profile view
this image will be shown on the
background. In most cases the
background image is not yet on
the right location immediately
after the import. We're going to
drag it to the correct place now.

Select Background image => Origin
from the pop-up menu.
The cursor now changes to a cross
with a big O indication you're going to
change the origin. Press the left
mouse button somewhere on the
background image and keep it pressed
down. If you move the mouse around
now you'll notice the background
image being dragged around as well. If
you release the mouse button again
the viewport will resume to normal
operation.
Drag the image to the correct location.
In this case the lowest point of the
skeg should coincide with the baseline
of your model (Z=0.0). The aft part of
the transom should coincide with the
aft perpendicular (X=0.0).
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5. Changing the scale of a background image
Description

Action

Once the background image is
on the correct spot we still have
to scale it to the correct
dimensions.

Select Background image => Set
scale from the pop-up menu. The
cursor changes to a ruler to indicate
you're changing the scale of the
image. Now click on a point of the
background image of which you know
the exact coordinates. The further this
point is away from the origin the better.
Once a point has been selected
another window shows up prompting
for the coordinates of the selected
point. Enter the correct coordinates in
this point and close the window.
In our example the coordinate of the
uppermost point of the bow is 6.75,
1.64

Important: All new background images will automatically have the
same scale applied as this one. This is particularly convenient if you're
importing multiple background images originating from the same
linesplan. So make sure you set the correct scale before importing the
next background image! In our case we import the same image three
times (once for each view) so having exactly the same scale for each
image is crucial.

6. Setting transparency of the background image
Description

Action

Background images with large
white areas, as is often the
case with a linesplan, can be
very dominant. You can avoid
this by assigning a transparent
color. Areas with the
transparent color will not be
drawn on your screen. In case
of a black and white linesplan
only the black lines will remain
visible.

Select Background image =>
Transparent color from the pop-up
menu. Click on a spot of your
background image with the color you
want removed. The background image
will now be redrawn in transparent
mode.
If you find the image still too dominant
try blending it with the background.
Use the Background image =>
Blending option from the pop-up
menu and move the slide bar until
you're satisfied.

Note: You can remove transparency again by repeating this process.
Instead of clicking on a spot within the background image simply select
a point outside the image.

7. Adjusting the transparency tolerance
Description

Action

Especially when using
compressed images like jpeg
areas that appear white can
consist out of many shades of
white. In that case if the
transparent color has been set
to white a lot of “nearly white”
noise remains visible. By
increasing the tolerance you
can remove that noise.

Select Background image =>
Tolerance from the pop-up menu.
Experiment a bit with the value until
you're satisfied with the appearance of
the background image. For most jpeg
images a tolerance of 35 works fine.
The higher the compression rate of the
file, the higher the tolerance needs to
be.
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8. Importing more images
Description
Repeat this process for the
bodyplan and plan view of your
model.

9. Assigning control curves
Description
Now we're going to assign a
control curve to the deckline.
This control curve is going to
be used at a later stage to:
1)

Match the shape of
the deckline of the
background images

2)

Fair the deckline in
such a way that we
end up with a very
smooth curve.

Action
Select all of the edges from the
deckline (see also step 2).
From the main menu select Edit =>
Curve => New.
A blue curve is now visible. It is better
visible if you hide the control net. You
can do this by selecting Display =>
Control net from the main menu. If the
curve is still not visible select Display
=> Control curves to turn of the
display of the control curves.
Repeat this to add a control curve to
the chine we've created in step 2.
Add a control curve to the contourline.
Select all edges on the centerplane of
the ship, including the edges of the
bow.
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10. Adding the other control curves
Description
If you've added all three
control curves your model
should look something like this.

11. Shaping the deckline
Description
The first thing we're going to
do is to try to match our
deckline to that of the
background image.

Action
Turn of the control net (see step 9).
Choose the plan view and select the
deckline. Once the deckline is selected
the controlpoints and edges used for
this curve will be shown together with
the curvature plot (the purple lines). If
the curvature plot is not visible there
are two possibilities:
1)

2)

Modifying the shape is done by
selecting a controlpoint of the
curve and dragging it to
another location.

The display of curvature
plots is disabled. Check (or
enable) it by selecting
Display => Curvature from
the mainmenu.

Illustration 4: Deckline before.

The scale of the curvature
plot is too small to be seen.
You can increase or
decrease the scale by
pressing F10 or F9.

Move the controlpoints with the mouse
to their new locations. Start with the
startpoint and endpoint. Then move
the interior points of the curve. If the
deckline is roughly similar to that of the
background image check your
curvature plot. Make sure the
curvature changes gradually along the
curve. If not then adjust the
controlpoints nearest to the curvature
peaks or valleys. Try to distribute the
points evenly along the curve
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Illustration 5: Deckline modified to match the background image.
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12. Shape the chine and profile
Description

Action

This process should be
repeated for the chine and also
for the profile of the hull.

13. Adapting the incremental distance
Description

Action

Now our hull looks the same in
the plan view as the original
linesplan. The profile however
still differs. Now we can switch
to the profile view and move
the points again with the
mouse. By doing so you run
the risk of accidentally shifting
the points in longitudinal
direction, undoing our precious
work of the previous step.

Modify the “incremental” distance.
This is the distance a point is being
moved if we press one of the cursor
keys on the keyboard. If you look at
the statusbar (see illustration 6) at the
bottom of the main program window
there's a panel saying “Incr. Distance
0.100”. Click on it with the mouse and
a window shows up requesting the
new distance. Set it to 0.01. Now each
time we press a cursor key the
selected controlpoint will be moved
0.01 meter.

14. Matching the profile view
Description
Now we're going to match the
controlcurves in the profile view
by moving controlpoints with
the cursor keys rather than with
the mouse.

Action
1)

Select one of the
controlcurves.

2)

Select a point on the
selected control curve. Start
with the start and endpoints
again.

3)

Move the selected point up
or down with the cursor
keys. Repeat this for all
points until the curve
coincides with the
corresponding curve of the
linesplan

4)

If you find that the
incremental distance is still
too large then reduce it.

5)

Repeat the process for the
other two curves.
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Illustration 6: DELFTship statusbar
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15. Use the shaded view
Description

Action

Congratulations! The main
feature lines of the hull are
finished and the boat should
look very similar to the one of
the linesplan. Now we're going
to visualize the surface of the
hull in 3D.

Select Mode => Shade from the popup menu in the perspective view. The
hull surface will be shaded using
virtual lights. Parts of the hull that are
submerged are shaded in grey whilst
the rest of the hull is shaded green.
You can rotate the model by keeping
the middle mouse button (or
mousewheel) pressed while moving
the mouse. If you have no middle
mouse button you can use the
scrollbars at the bottom and to the
right of the perspective view.

16. Adding a new face
Description

Action

Our boat has no transom yet. Switch to perspective view.
We're going to add a new face Select the points shown on illustration
manually to fill in the transom. 7. Start with the point on the
centerplane, then the point on the
chine and finally the point on the
deckline. If you need to select more
than one point you need to keep the
CTRL-key on your keyboard pressed.
Select Edit => Face => New from the
mainmenu to add the new face.
Your model will look now like the one
shown on illustration 8.
Illustration 7: Selecting points

Illustration 8: The new face added
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17. Setting the crease property
Description
By adding the new face the
two edges that form the
transition of the transom into
the bottom and side if the hull
have changed from crease
edges to non-crease edges.

Action
By now you should be able to modify
the crease property of the two edges.
If you're not sure just have another
look at step 2. Select the two edges
and make them knuckle lines again.

18. Inserting new points
Description
The transom is triangular in
shape. We're going to insert a
new point in the transom to
modify its shape.

Action
Select the edge of the transom.
Select Edit => Edge => Split from the
mainmenu. A new point is inserted in
the middle of the selected edge
causing the edge to be split in two.

17. Modifying the location of a point manually
Description
The new location of the new
point needs to be adapted to
put it on the centerline of the
hull.

Action
Modify the coordinate by specifying
the following values in the controlpoint
window that shows the alpha
numerical values of the controlpoint:
X-coord : 0.1398
Y-coord : 0.0000:
Z-coord : 1.1160

Illustration 9: Point moved to the centerline
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18. Creating cornerpoints
Description

Action

Illustration 9 shows that the
transom does not go through
the new point but curves down.
You can force the surface
through that point by making it
a corner point.

In the previous step we've modified
the values of the point manually in the
controlpoint window. This window also
has a checkbox that says “Corner”
Make sure this checkbox is checked.
Your transom will now look like the
one on illustration 10.

Illustration 10:
10: The cornerpoint has been set.

19. Adding new layers.
Description
We're going to add two new
layers so we have three
different layers. One layer each
for the bottom, side and
transom.

Action
Open the layer dialog by selecting
Edit => Layer => Dialog... from the
mainmenu (or by pressing CTRL-L
shortcut on the keyboard). After the
layer windows shows up, modify the
name of the current layer, which is
“layer 0” into “Side panel”.
Now press the “New layer” button on
the toolbar from the layer window. It's
the leftmost button that displays the
hint “Create a new empty layer” when
you hover over it with the mouse. A
new layer is created. Set the name of
this layer to “Bottom panel”.
Add another layer with the name
“Transom”

20. Display the interior edges
Description

Action

The two new layers we've just Select Display => Interior edges
created are still empty. In order from the mainmenu. The interior edges
to be able to select faces the
will now be drawn.
interior edges must be
displayed. The interior edges
are in fact the edges of the
subdivided surface mesh. The
higher the precision setting of
your model, the larger the
number of displayed edges and
faces will be.
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21. Selecting (a group of) faces
Description
Now the interior edges are
visible you'll be able to select
the faces.

Action
Click on one of the small green lines
of the bottom. The face it belongs to
will be selected and all the subdivided
edges belonging to this face will be
drawn in yellow indicating this face is
selected. You can repeat this for all
the faces in the bottom panel but
there's another way to quickly select a
group of faces. If you select a face
while keeping the CTRL-key on your
keyboard pressed the program
assembles all faces that:

•

Belong to the same layer as
the face you've just
selected.

•

Are connected to the
selected face.

•

The program stops if a
knuckle line is encountered.

This is a convenient way to select the
entire bottom or side panel in one
pass.
Note: The thin white lines that are drawn are called “normals”. They
indicate the facing of the surface. For hydrostatic calculations it's
crucial the front side of each face is on the side of the water. The
normals should point outside the hull, not inside!

22. Assign faces to a different layer.
Description

Action

This step shows how to assign Go to the layer toolbar on the top of
the faces you've just selected the program window. It is shown on
to a different layer.
illustration 11.
If you have no faces selected then this
toolbar shows the name of the
currently selected layer.
If you have just selected some faces
then there are two possibilities:
1)

All the selected faces
belong to the same layer. In
that case the name of that
layer is shown.

2)

The selected faces belong
to multiple layers. In that
case the field remains white
an no layer name is shown
at all.

Click on the arrow button to make all
layers visible and click on the entry in
the list that says “Bottom panel”.
You've just assigned the selected
faces to the bottom panel layer. Press
the Esc-key or Selection => Deselect
all from the mainmenu to clear the
selection.
Repeat this to assign the faces of the
transom to the transom layer and the
faces forming the side panel to the
side panel layer.
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Illustration 11:
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23. Adding stations
Description

Action

In this step we are going to
There are two different ways to obtain
add stations to the model we
the locations of the stations:
have created. It is crucial that
1) Measure them from a
these stations are placed at the
printed version of the
same longitudinal position as
background image by hand
the stations of our background
using a ruler and calculator.
image. That way we can
2) Hover with the mouse over
compare our linesplan against
the stations of the
the background image to check
background image in either
for differences.
the profile view or the plan
view of DELFTship. The
caption bar of the window
showing this view displays
the coordinates of the
mouse. This is the easiest
way. Write down the
positions of all the stations
on a piece of paper. You
can see the locations
measured from our model
on the illustration to the
right.
Call the intersection window by
selecting View => Intersections...
from the mainmenu. This window
shows which intersections are currently
defined.
Clear any present stations by pressing
the trash button (7th button from the
left)
Add the stations one by one by
pressing the +1 button (5th button from
the left) and specifying the correct
location.

24. Compare the model against the background image
Description

Action

The bodyplan view is used to
check how the stations we've
just added compare to the
stations of the background
image.

Select the bodyplan view. Make
sure the display of interior
edges is off (step 20).
If you've added the stations at
the right locations DELFTship
will now draw them on the same
location as the ones from the
background image. They look
very similar. If you look closely
though you'll notice that the
original stations at the stern are
slightly curved at the side, while
ours are straight.

11

DELFTship tutorial – Using background images
DELFTship

25. Adjusting the side panel.
Description

Action

The side panel needs
adjustment to create the curved
stations at the stern. To do that
we need to insert new points to
be able to pull the surface
outwards in the middle of the
panel.

Select all the vertical edges of the side
panel. Make sure you select them in
chronological order because that will
come in handy for the next step. Start
with the edge on the centerline of the
transom and work your way up to the
front of the boat.

26. Insert new points in the side panel.
Description

Action

During this step the new points Select Edit => Edge => Split from the
are inserted into the side panel. mainmenu. All selected edges are split
in two and the new points are
automatically selected. If you have
selected the edges in chronological
order then the new points are selected
in the same order. That will be
convenient for the next step.

27. Connect the new points with edges.
Description

Action

The new points need to be
connected with edges to
maintain a regular network. All
faces should consist of 4 points
whenever possible and every
point in the interior of the
surface should be connected to
4 faces and four edges. This is
crucial if you want a good
faired surface.

Select Edit => Edge => Insert from
the mainmenu. If you've selected the
edges in the correct order in step 25
then all the points will be connected to
each other with new edges as shown
to the right. If the new edges do not
run continuously from the transom to
the stem (there's a gap) then simply
select the two endpoints and repeat
the process.
Remember that in order to insert a
new edge between two selected points
the points must share the same face!

12

DELFTship tutorial – Using background images
DELFTship

28. Adjust the shape of the side panel.
Description

Action

With the new points inserted
we can start adjusting the
shape of the side panel.

Switch back to the bodyplan view.
Make sure the control net is visible.
Carefully move the new points a little
outwards until the shape of the
stations is the same as the original
stations. The bow needs no
adjustment so the displacement of the
points should gradually reduce to zero
while you work your way to the front.
This is an iterative process, so keep
adjusting the control points until you're
satisfied with the shape of the stations.

29. Creating a curved transom.
Description

Action

The transom of our new hull is
still flat. The original transom
shows a radius in the plan
view. To adjust the shape of
the transom we need to insert
some points and edges again.

Select the three horizontal edges from
the transom.
Insert new points on these edges. If
your not sure how to do this then have
a look at step 26.
Connect the new points by inserting
new edges (see step 27).
Your transom should look now like the
one displayed to the right.

30. Modifying the shape of the transom
Description

Action

To adjust the shape of the
Go to the plan view. Shift the new
transom the new points need to points so that the top and bottom
be shifted.
edges of the transom coincide with the
ones of the background image
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31. Making sure that transom is perpendicular to the centerplane
Description
Although the transom may look
right it's not completely finished
yet. We have to make sure that
where the transom ends at the
centerplane it is perpendicular
to the centerplane. Otherwise it
would like there's a knuckle line
running vertically over the
middle of the transom

Action
Select the top edge of the transom
(the one nearest to the centerplane).
Make sure that the startpoint end
endpoint have exactly the same Xcoordinate. If not, them adjust one of
them manually.
Do the same for the middle and lower
edge as shown to the right.
If the shape of the transom has
changed significantly it might be
necessary to repeat step 30 and 31
until the shape is satisfactory.

That's it!
You've now successfully recreated a linesplan. If everything has been done correctly you should have ended
up with a boat that should be very similar to the one shown below.
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