Boat Design Forums  |  Boat Design Directory  |  Boat Design Gallery  |  Boat Design Book Store  |  Thanks to Our Site Sponsors
  #1  
Old 04-07-2017, 07:20 PM
rovi rovi is offline
Junior Member
 
Join Date: Jul 2011
Rep: 10 Posts: 59
Location: ANTIGUA & BARBUDA
2007 mercury optimax 150 probl

Hi all, I have a new issue with optimax 150. Was working quite well then it immediately stopped idling. The air and fuel injectors seem to be pulsing properly but three spark plugs have heavy soot or carbon deposits on them after every attempt to start the engine. The plug positions are 1 3 and 4; I would really an understanding of what's the cause and the solution to this problem. Thanks and I'm anticipating some help.
Reply With Quote
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Optimax injection issue rovi Outboards 0 10-21-2015
03:12 PM 
Mercury OptiMax 200XS SST CAD Model orphic Outboards 0 04-03-2012
10:45 AM 
1995 Mercury 150 HP toveri Outboards 0 05-25-2009
09:51 AM 
Mercury 115 optimax performance UPGRADES!! Raxxor Outboards 0 12-18-2006
05:34 PM 
Merc OB optimax cco12 Powerboats 2 05-19-2003
12:08 PM 

Forum posts represent the experience, opinion, and view of individual users. Boat Design Net does not necessarily endorse nor share the view of each individual post.
When making potentially dangerous or financial decisions, always employ and consult appropriate professionals. Your circumstances or experience may be different.

All times are GMT -5. The time now is 04:50 AM.


Powered by: vBulletin Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Web Site Design and Content Copyright ©1999 - 2017 Boat Design Net