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In this chapter 

Surfacing Wireframe
Models

This chapter introduces wireframe surface modeling, one of 

the key uses for surface modeling. You learn an approach to a 

surfacing project and techniques for achieving the designer’s 

intent. The tutorial provides instructions for surfacing a wire-

frame model of a pump housing. The wireframe is the outline 

of a pump housing, the only data you have to work with.

You should already know how to create surfaces before you 

begin this lesson. If you do not, complete the exercises in 

chapter 12, “Creating and Editing Surfaces.”

■ Studying the design 
intent and developing 
a strategy

■ Identifying logical 
surface areas

■ Identifying base 
surface areas

■ Using creative tech-
niques to surface a 
wireframe model

■ Verifying surfacing 
results
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Key Terms

Term Definition

base surface A basic underlying surface that carries a shape across a larger area. May be trimmed to 
precise shapes as needed but the base surface remains intact and may be displayed.

logical surface area An area that can be described by a single surface.

projected wire A 2D line that represents an opening on a surface and trims a hole in the surface. 
May also be a 3D polyline that represents the extents of the opening in the 
wireframe.

watertight Surfaces conform to the wireframe model and gaps between surfaces are within 
allowable tolerances.
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Key Concepts
A completely surfaced model is a single electronic master suitable for engi-
neering and manufacturing activities, such as

■ Generating accurate sections for engineering and packaging studies.
■ Providing input for finite element modeling and analysis.
■ Producing shaded renderings for marketing.
■ Providing input for rapid prototyping equipment.
■ Supplying rotated surfaces for tool, mold, and die design.
■ Supplying surfaces for numerical control machining of models and tools.

Building on your knowledge of surface types, you examine the wireframe to 
be surfaced and determine which surface will produce the best results.

Discerning Design Intent
Because wireframe models have complex shapes, they are almost always made 
up of many surfaces joined together. For a model like the pump housing, you 
will use many different individual surfaces to completely define it. When you 
surface a wireframe model, you are really completing its design.

Before you begin, you analyze the design and make some decisions so that 
you can achieve your design goals. Although it is tempting to simply begin 
modeling, this process can help avoid errors. In general:

■ Study the data to understand the design intent.
■ Identify the location and extent of each surface area.
■ Identify the base surface area(s) that may be later trimmed to adjacent sur-

faces and wires.
■ Determine where you can use trimmed planar (flat) surfaces.
■ Decide on the best surface types and approach for combining them.
■ Create additional geometry as needed to resolve problem areas.
■ Verify your surfacing results.
■ Add the finishing touches to a watertight model.
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Review the wireframe in detail, to discern where you will have design challenges. 
Consider the following:

■ The complexity of the surfaces you need to create. For example, what 
curvature is required of surfaces? Is it sufficient to have surfaces with no 
curvature (such as ruled surfaces), or will you need surfaces with multiple 
curvatures?

■ How you can simplify shapes. Surfaces created from polylines or splines 
with a large number of points are unnecessarily complex and greatly 
increase computation time.

■ Which surfaces are continuous. Continuous surfaces are smoother and 
take less time to compute. You can set preferences to prevent lines with 
breaks or changes in curvature from being converted to splines.

■ Whether default preference settings are appropriate for the model. Allow 
as much tolerance as is practical to avoid converting polylines to splines. 
Splines take longer to compute than polylines, a factor that becomes more 
important with complex models.

Identifying Logical Surface Areas
Now that you know the intent of the pump design, you have an idea of the 
requirements that affect its shape and how you can construct it. Try to iden-
tify the location and extent of each logical surface area, an area that can be 
described by a single surface.

A surface must be smooth and free from sharp breaks. Often, an individual 
surface area is clearly defined because it is surrounded by sharp break lines on 
all sides. The pump top is clearly a surface because it is surrounded by sharp 
edges on three sides, and the fourth edge is the end of the part.

Likewise, the side of the top part of the pump constitutes a single surface. 
Each of these two surface areas requires a surface because no single surface 
could cover both.
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Surfaces may contain multiple wires.

All lines inside the four boundaries share the same smooth curvature as the 
boundary edges. There are no abrupt curvature changes, so the goal should 
be to surface the entire area with a single surface, using the additional wires 
to constrain the surface shape.

Identifying Base Surface Areas
The bottom of the pump housing appears to be a smoothly curved area. How-
ever, at the top edge, there is an almost 90-degree bend. Also, a flanged area 
is formed by a slot opening in the otherwise smooth area.

The primary guideline in wireframe surfacing is to create an acceptable 
surface first. Later, add a hole by trimming the surface with the shape of the hole.

In general, use only smooth wires to create surfaces. When you use a wire 
with sharp corners, those sharp areas do not produce an acceptable surface.

wireframe surface

pump housing close-up

top edge

TIP

wireframe unacceptable surface



Chapter 13 Surfacing Wireframe Models

356

Therefore, you need to find some other way to surface the area. Consider the 
area again, looking for the design intent. A second look reveals a flat surface 
on the front of the pump housing that intersects a smoothly curved surface 
at the bottom.

How do you know that the front surface is flat? One way to check is to look 
at the top line in another view to confirm it. Thus, the approach to surfacing 
that area is to create the smooth bottom surface and the flat surface. Then 
intersect one with the other and create a wire at their intersection. If the new 
wire that the intersection creates is the same as the existing wire in the wire-
frame model, you have confirmed that you were correct in your observation 
and surfacing approach.

Next, consider the bottom surface. You already know that you cannot use the 
top wire because it has an abrupt corner. A good approach would be to use 
only the bottom wire as a rail, and the far edge as a cross section.

A surface like this one is a basic, underlying surface that carries a shape across 
larger areas. In the Mechanical Desktop, this surface is referred to as a base 
surface. Even after many areas of the surface are trimmed away, the underly-
ing base surface remains intact and may be displayed at any time with the 
Surface Display dialog box.

rail section

surface
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The ability to identify base surfaces quickly is an important part of wireframe 
surfacing. Another good approach is to quickly categorize surfaces by type 
and eliminate unsuitable ones from further consideration.

To get shapes you can use for creating surfaces, you may need to break 
polylines into segments. Then, combine selected segments to form boundaries 
for individual surfaces.

Using Trimmed Planar Surfaces
Use a trimmed planar surface for an area that you know is a flat plane. By 
glancing at the pump model you can see areas that appear to be flat and can 
be surfaced with trimmed flat planes.

base surface trimmed surface

TIP
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If you are in doubt about whether a given area is flat, try to make a planar 
surface. A planar surface requires a single closed wire as its boundary.

If the wire is not a closed single loop, when you select it you can see the breaks 
in the wire.

You can join line segments into a closed wire that forms the boundary of a 
planar surface. The surface is trimmed to the boundary shape.

When joining line segments, set tolerances to compensate for imper-
fect wireframe data that would otherwise cause the surface to fail.

You must judge if a given area was meant to be flat. If it is flat within the 
tolerance, create a perfectly flat surface and adjust the edges accordingly.

Choosing a Surfacing Method
It may not be clear which type of surface is best suited for a given area.

wire planar surface

closed wire multiple wires

NOTE

top area
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In this example, the top area of the pump is not suitable for a single surface 
because there are abrupt changes in its smoothness. The center area is curved 
in one direction but straight in the other. When you have a surface area that 
can be defined by a straight line between two curves, you can create a ruled 
surface between the two curves.

Look beyond the obvious visible surface to find a workable solution. Because 
the inlet at the right top area of the pump extends from the surface, consider 
making the base surface first and then trimming it to the correct shape.

With the inlet shape removed, you can see possibilities for surfaces. The shape 
created by the four wires contains a sharp corner. Avoid creating a surface from 
these four wires because they might produce a surface that is not smooth.

possible surface wire

inlet

abrupt corner
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You can see that each end of the area beneath the inlet is described by lines 
with curvatures in both directions. This offers you a choice of surfacing 
methods, such as a swept surface or a lofted UV surface.

In most cases, there is more than one way to surface an area. Try both methods 
here, compare the results, and choose the one that produces the better result.

■ Swept surfaces give you more control over the shape of the mid-portion 
of the surface.

■ Lofted UV surfaces have fewer controls but risk is minimized.

Once you create a base surface to cover an area, trim the surface back to the 
wire with the abrupt edge.

Use trimmed surfaces to create smooth underlying base surfaces that remain 
a permanent part of a surface definition. Trim to constrain the edges and you 
achieve smoothness in a base surface that contains no abrupt corners in its 
boundary wires, yet creates a logical surface bounded by different edges. The 
logical surface can contain any number of sharp corners, which have no 
effect on the smoothness of the base surface.

The opposite side of the pump top area may also be surfaced several ways. 
Again, the surface is really a larger surface cut short by an intersecting area of 
the pump. This time, the wire that terminates the surface has no abrupt cor-
ners, so it could be used as one of four sides of a swept or lofted UV surface.

swept surface lofted UV surface

base surface trimmed surface
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The easier method in this tutorial uses a single rail and a single section to sur-
face the entire area and then trims the base surface to the intersecting part of 
the pump.

This choice might not always be correct. As you gain experience, you can pre-
dict which approach would yield the most accurate results. In the previous 
example, you should verify that the surface created without the top line 
matches the top line within a reasonable tolerance.

Always check the fit between a newly created surface and existing wires to be 
sure that you are not deviating too far from the wireframe data. If the new 
surface is not within tolerance to the existing top line, the surface does not 
accurately reflect the wireframe. You can re-create it using all four wire edges.

Verifying Surfacing Results
As you gain experience, you will see the importance of learned skill and judg-
ment. Your challenge is always to produce smooth surfaces that fit the wire-
frame closely and are not unnecessarily complex.

There are a number of ways to judge the smoothness of surfaces:

■ Create and review flow lines in different rotated views.
■ Cut sections through a complete set of surfaces, and then examine the 

ends to see how closely they match at the edges.
■ Shade or render a surface. However small deviations in surface smoothness 

may go undetected because the rendering software is designed to smooth 
the rendered model.

■ Create augmented flow lines with long vectors on the surface and examine 
the smoothness of the vector ends. The ends of the vectors greatly exagger-
ate the smoothness of the surface, and areas where it is not smooth will 
become apparent.

rail

section

surface trimmed surface
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Surfacing a Wireframe Model
Now that you have analyzed approaches to surfacing the pump housing and 
practiced surfacing techniques, you are ready to surface the pump in sections.

A surface modeling project may begin with a wireframe, whether it is a DXF 
or an IGES file from a client or a 2D or 3D CAD design you created yourself. 
In order to describe the 3D object, most designers begin with a 2D drawing.

In this lesson, you create surfaces for an actual part, a wireframe model of a 
hydraulic pump. The surfaced model provides the manufacturer with infor-
mation used to create prototypes or to NC-machine the actual patterns, molds, 
and tooling.

To set up your file

1 Copy the t_pump.dwg file.

It is good practice to copy tutorial files so that you can always open the 
original drawings. That way, any mistakes you make while you are learning will 
not replace the master tutorial files. For more information about how to copy 
tutorial drawing files, see “Copying Tutorial Drawing Files” on page 34.

2 Choose Surface ➤ Preferences.

3 In the Desktop Preferences dialog box, select the Surfaces tab. Specify:

Surface Properties:
U Display Wires: Enter 5
V Display Wires: Enter 5
Surface/Spline Options:
Polyline Fit Length: Enter 1
Polyline Fit Angle: Enter 150

4 Choose Model Size, then Measure Model.

The size 4.7223 inches is displayed. Choose OK twice to exit the dialog boxes.

These settings affect the visual representation of the surfaces and the size of 
the surface normal.

Choose Assist ➤ Layers and Lines.

TIP
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5 In the Layer and Linetype Properties dialog box, select the Layer tab. Select 
layer 10, and click Current.

6 Press SHIFT and select layer 20 and the last layer. In the second column, click 
F to freeze all selected layers. Then freeze layer 0.

All layers except Layer 10 should be frozen (snowflake icon). Only Layer 10 
is thawed (sun icon).

Choose OK to close the dialog box.

The labeled parts of the pump are on separate layers. As you work on each 
one, you make its layer current and freeze other layers to make them inactive.

outlet

body

inlet

top

basesupport
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Creating Trimmed Planar Surfaces
Begin by surfacing the top section of the pump model, creating the individual 
surfaces. Top A is a planar surface because it is flat with sharp edges. Tops B 
and C are swept surfaces, bounded by curved wires. Top B uses two curves and 
two rails, and top C uses only one curve and one rail. Later you trim top C 
surface where it extends beyond the wireframe boundary.

As you gain experience using the menu selections that correspond to 
commands in this lesson, you begin to use shortcuts. For a list of shortcuts that 
automate selection of menu options and commands, see “Using Accelerator 
Keys” on page 28.

For a trimmed planar surface, the surface must be a single polyline that 
lies in a single plane. If the wireframe is composed of multiple polylines, you must 
join them into a single polyline before you create the surface.

To create the top A, B, and C surfaces

1 Use ZOOM to enlarge the view.

2 Choose Surface ➤ Create Surface ➤ Planar Trim.

Select wires: Select wire (1) and press ENTER

TIP

top G

top C

top D

top A

top E

top F

top B

top A

TIP

1

2

4

3

5

6

7
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A planar surface, trimmed to the boundary of wire (1), is created on the top 
of the model. Next, create the top B surface.

3 Choose Surface ➤ Create Surface ➤ Sweep.

Select cross sections: Select wires (2) and (3) and press ENTER
Select rails: Select wires (4) and (5)

In the Sweep Surface dialog box, specify:

Transition: Scale, then OK

4 Choose Surface ➤ Create Surface ➤ Sweep.

Select cross sections: Select wire (6) and press ENTER
Select rails: Select wire (7) and press ENTER

In the Sweep Surface dialog box, specify:

Orientation:  Normal, then OK

The surface extends beyond the far side of the top. You trim it later.

5 Use CHPROP to move surfaces A, B, and C to the TOP layer.

Select objects: Select surfaces (A), (B), and (C) and press ENTER
Change what property (Color/LAyer/LType/ltScale/Thickness): Enter La
New layer <10>: Enter top
Change what property (Color/LAyer/LType/ltScale/Thickness): Press ENTER

The surfaces are now on the TOP layer. Because the TOP layer is frozen, you 
cannot see the surfaces, although the wireframe is still visible.

6 Use REDRAW to refresh the display.

C

A

B
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7 Save the file.

The D and E surfaces are ruled surfaces.

To create the top D surface

1 Choose Surface ➤ Create Surface ➤ Rule. Create the top D surface.

Select first wire: Select wire (1)
Select second wire: Select wire (2)

2 Use BREAK to create a separate line segment for the top polyline, line (4).

Select object: Enter end
of: Select line (3)
Enter second point (or F for first point): Enter @

Unless you enter @, the adjoining portion of the polyline is deleted. The 
@ symbol breaks the polyline at the specified location and retains both segments.

D

E

3
4
52

1

TIP
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To create the top E surface

1 Choose Surface ➤ Create Surface ➤ Rule.

Select first wire: Select line (4)
Select second wire: Select line (5)

2 Use CHPROP to move top D and top E surfaces to the TOP layer.

Select objects: Select surface (D)
Select objects: Select surface (E) and press ENTER
Change what property (Color/LAyer/LType/ltScale/xx: Enter La
New layer <10>: Enter top and press ENTER

Save the file.

Next, break and join lines that are needed to create the top F planar surface.

To create the top F surface

1 Use BREAK to break polyline (1) where it intersects polyline (2).

Select object: Select polyline (1)
Enter second point (or F for first point): Enter f
Enter first point: Enter int
of: Select polyline (2) at the intersection
Enter second point: Enter @

To check whether the polyline is broken properly, select it. Grip points 
should appear only for the line segment you select. Press ESC twice to exit 
Grip mode.

trimmed planar surface

1
2

TIP
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The break creates a line segment you use as part of the boundary for the next 
surface. Join the polylines that form the boundary of top F.

2 Choose Surface ➤ Edit Wireframe ➤ Join.

In the Join3D dialog box, specify:

Mode: Automatic
Output: Polyline, then OK 
Select start wire: Select polyline (1)

Select all wires you want to join, including the first wire:

Select wires to join: Select polylines (1) through (5) and press ENTER
Reverse? Yes/<No>: Press ENTER to accept the direction of the new wire

The duplicate wire is removed (polyline 1), and the remaining wires are 
joined into a polyline.

To confirm that the lines are joined, select the line and check the grip 
points.

3 Choose Surface ➤ Create Surface ➤ Planar Trim.

Select wires: Select the joined polyline and press ENTER

You have created the trimmed planar surface. Save the file.

For the top G surface, extrude a polyline along a straight line and then trim 
the surface to the desired shape.

1

2 4

3

5

TIP
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To create the top G surface

1 Choose View ➤ Model Views ➤ Left Isometric.

2 Choose Surface ➤ Create Surface ➤ Extrude. Extrude polyline (1) down wire (2).

Select wires: Select polyline (1) and press ENTER
Direction: Viewdir/Wire/X/Y/Z/<Start point>: Enter w
Select wires: Select polyline (2)
Flip/<Accept>:

Flip the direction arrow to extrude the surface toward the part and press ENTER
Taper angle <0>: Press ENTER to accept the default

Your selection point determines the extrusion direction. The illustration 
shows the direction when you select polyline (2) close to polyline (1). If you 
selected below the midpoint of the wire, the direction of the extrusion is reversed.

Your illustration should now look like this.

3 Use CHPROP to move top F and top G to the TOP layer. See the diagram at 
“Creating Trimmed Planar Surfaces” on page 364.

Select objects: Select surface (F)
Select objects: Select surface (G) and press ENTER
Change what property (Color/LAyer/LType/ltScale/xx: Enter La
New layer <10>: Enter top and press ENTER

4 Choose Layers.

Thaw the TOP layer to see all the surfaces you have created.

2

1

NOTE
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5 Choose Surface ➤ Edit Surface ➤ Intersect Trim. Trim top G and top C at their 
intersection.

Select first surface: Select surface (1)
Select second surface: Select surface (2)

In the Surface Intersection dialog box, specify:

Intersection: Clear Polyline
Trim: First Surface and Second Surface, then OK

The surfaces are trimmed where they intersect. Save the file.

Joining Surfaces on a Complex Shape
Next, surface the inlet portion of the pump. Because the inlet has a complex 
shape, you will need five surfaces to represent its shape.

■ Inlets A and C are ruled surfaces because they follow two polylines.
■ Inlet B is an extruded surface that is trimmed to its final shape.
■ Inlet D is a surface blended to surfaces B, C and E.
■ Inlet E is a trimmed planar surface created from joined lines that form its 

boundary.

1

2

inlet E

inlet D

inlet A

inlet B

inlet C
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Be sure to select surfaces and lines where indicated on the illustrations. To 
make it easier to select precisely, zoom in as needed.

To create the inlet A surface

1 Choose Assist ➤ Layers and Lines.

In the Layers dialog box, thaw layer 20 and make it the current layer. Then 
freeze layer 10 and TOP.

2 Choose View ➤ Model Views ➤ Right Isometric. You have restored the isometric 
view. Next, you create the inlet A surface.

3 Choose Surface ➤ Create Surface ➤ Rule.

Select first wire: Select wire (1)
Select second wire: Select wire (2)

The ruled surface is created on the top of the inlet.

4 Use CHPROP to move the inlet A surface to the INLET layer.

Select objects: Select inlet A surface and press ENTER
Change what property (Color/LAyer/LType/ltScale/Thickness): Enter La
New layer <20>: Enter inlet
Change what property (Color/LAyer/LType/ltScale/Thickness): Press ENTER

Inlet B is an extruded partial cylinder, trimmed to its final shape by a closed 
wire. The surface is extruded across the inlet wireframe.

The direction of the extrusion is determined by where you select the wire. If 
you need to, you can flip the direction of the extrusion.

You create a ruled surface for inlet C.

TIP

2

1

inlet A
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To select the wires, you might need to rotate the view. Use icons on the 
Desktop View toolbar to reposition the view or use VPOINT to specify a viewpoint.

To create the inlet B surface

1 Choose Surface ➤ Create Surface ➤ Extrude.

You extrude polyline (1) along line (2).

Select wires: Select polyline (1) and press ENTER
Direction: Viewdir/Wire/X/Y/Z/<Start Point>: Enter w
Select wire: Select polyline (2) near (1)
Flip/<Accept>:

Flip the direction arrow as necessary to extrude the surface and press ENTER
Taper angle <0>: Press ENTER

A close look at the inlet reveals that the extruded surface extends beyond the 
wireframe. You trim the inlet B surface to the boundary of surface D.

2 Reset the DELOBJ variable so that the projected wire is not deleted.

New value for delobj <1>: Enter 0

Next, project the edge of inlet D to trim the inlet A surface.

3 Choose Surface ➤ Edit Surface ➤ Project Trim.

Select wires to project: Select line (1) and press ENTER
Select target surfaces: Select surface (2) and press ENTER

TIP

2

1

1

2
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In the Project to Surface dialog box, specify:

Direction: Normal to Surface
Output type: Trim Surface, then OK

If you want to delete the wire or line you use to create a surface, reset the 
DELOBJ variable to the default setting of 1 (delete the object).

You have trimmed inlet B by projection. Next you create inlet C, a ruled 
surface between two wires.

To create the inlet C surface

1 Choose Surface ➤ Create Surface ➤ Rule.

Select first wire: Select wire (1)
Select second wire: Select wire (2)

Your model should look like this.

2 Use CHPROP to move inlet B and C surfaces to the INLET layer.

3 Save the file.

Next, you create inlet D, a surface blended from the edges of inlet B and C 
surfaces and the polyline that defines the edge of inlet E.

You may need to rotate the model to show the intersection clearly.

TIP

1

2

NOTE



Chapter 13 Surfacing Wireframe Models

374

To create the inlet D surface

1 Break the polyline into two line segments.

Select object: Select polyline (1)
Enter second point (or F for first point): Enter f
Enter first point: Enter int
of: Select polyline (2)
Enter second point: Enter @

Check grip points of the line segments after you break it.

2 Choose Surface ➤ Create Surface ➤ Blend.

Be sure to make selections in order. When you make selections for blend-
ing a surface, do not make the selections consecutively in a ring.

Select first wire: Select wire (1)
Select second wire: Select wire (2)
Select third wire: Select wire (3)
Select fourth wire: Select wire (4)

1

2

TIP

TIP

2

4

1

3



Joining Surfaces on a Complex Shape

375

The blended surface should look like this.

3 Use CHPROP to move the surface to the INLET layer.

Join the lines to form the boundary of inlet E and then create a trimmed planar 
surface from the joined lines. Zoom in as needed to make line selection easier.

To create the inlet E surface

1 Choose Surface ➤ Edit Wireframe ➤ Join.

In the Join3D dialog box, specify:

Mode: Automatic
Output: Polyline
Gap Tolerance: .01, then OK 
Select start wire: Select polyline (1)

Select all wires you want to join, including the first wire.

Select wires to join: Select wires (1) through (4) and press ENTER
Reverse? Yes/<No>: Press ENTER

The duplicate wire (wire 1) is removed and all line segments are joined.

This procedure joins lines regardless of their original direction and 
explodes arcs and splines into polylines.

1

2
3

4

NOTE
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2 Choose Surface ➤ Create Surface ➤ Planar Trim. Create a trimmed planar sur-
face from the joined lines.

Select wires: Select polyline (1)
Select wires: Press ENTER

Your surface should look like this.

3 Use CHPROP to move inlet E to the INLET layer.

Now you can trim top D by projecting the edge of the inlet. Thaw layers to 
show the inlet and top sections of the pump. Then break a polyline into 
segments. Select segments to join; the joined polylines form the shape of the 
projection that cuts material where the two surfaces intersect.

To make selection easier, zoom and rotate the view as needed.

When you want to create an opening or a hole, project a wire onto a sur-
face to remove the portion of the surface bounded by the wire. Choose Surface 
➤ Edit Surface ➤ Project Trim.

To trim surfaces by projection

1 Thaw layers 10 and 20.

2 Choose View ➤ Model Views ➤ Right Isometric.

3 Break the polyline.

Select object: Select polyline (1)
Enter second point (or F for first point): Enter f
Enter first point: Enter end
of: Select polyline (2)
Enter second point: Enter @

TIP
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Use icons on the Desktop View toolbar to rotate the view and zoom in to 
show the lines clearly. If you prefer, use VPOINT to set a precise viewpoint. In this 
case, set the coordinates 4,-6,1 to show the lines you need for the next step.

4 Use BREAK to break the upper part of the polyline into segments.

Select object: Select polyline (1)
Enter second point (or F for first point): Enter f
Enter first point: Enter int
of: Select polyline (2)
Enter second point: Enter @

Next, you combine three polyline segments.

2

1

TIP

1

2
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5 Choose Surface ➤ Edit Wireframe ➤ Join. In the Join3D dialog box, specify:

Mode: Automatic
Output: Polyline
Gap Tolerance: Enter .004 and choose OK
Select start wire: Select polyline (1)

Select all wires you want to join, including the first wire:

Select wires to join: Select wire (1)
Select wires to join: Select wire (2)
Select wires to join: Select wire (3) and press ENTER
Reverse? Yes/<No>: Press ENTER

The duplicate wire (wire 1) is removed and the segments are joined together. 
Later, you will project the joined line onto the top surface.

6 Freeze layer 10 and thaw the TOP layer.

7 Choose View ➤ Model View ➤ Right Isometric. Reset the DELOBJ system vari-
able to 0 so that the wires are not deleted.

8 Choose Surface ➤ Edit Surface ➤ Project Trim. Cut top B where the inlet fits.

Select wires to project: Select wire (1) and press ENTER
Select target surfaces: Select surface (2) and press ENTER

3

2

1
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In the Project to Surface dialog box, specify:

Direction: Normal to Surface
Output Type: Trim Surface, then OK

Top B is cut open for the inlet. The top and inlet are complete.

9 Reset the DELOBJ system variable to 1 and save the file.

1

2
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Creating Swept and Projected Surfaces
For the main body of the pump, you continue building and trimming 
surfaces to their correct shapes.

■ Body A, B, and C are swept surfaces created from curves and rails.
■ Body D is a surface created from the boundaries of Body A, B, and C 

surfaces.

To create the body A, B, and C surfaces

1 Thaw layer 30 and make it current. Freeze layers 10, 20 and TOP.

2 Choose Surface ➤ Create Surface ➤ Sweep. Create the body A surface on the 
right side of the model.

Select cross sections: Select wire (1)
Select cross sections: Select wire (2) and press ENTER
Select rails: Select wire (3)
Select rails: Select wire (4)

body A

body C

body B

body D
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In the Sweep Surface dialog box, specify:

Transition: Scale, then OK

3 Choose Surface ➤ Create Surface ➤ Sweep. Create the body B surface on the 
left side of the model.

To repeat the previous command, press ENTER or the spacebar.

Select cross sections: Select wire (5) and press ENTER
Select rails: Select wire (6) and press ENTER

In the Sweep Surface dialog box, specify:

Orientation:  Normal, then OK

4 Choose Surface ➤ Create Surface ➤ Sweep. Create the body C surface near the 
bottom of the model.

Select cross sections: Select wire (7) and press ENTER
Select rails: Select the wire (8) and press ENTER

In the Sweep Surface dialog box, specify:

Orientation: Normal, then OK

1

3

4

2

8

5

6

7

TIP
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Your model should look like this.

5 Thaw layer 20 to reveal the inlet.

6 Reset the DELOBJ system variable to 0 so that the projected wire is not deleted.

7 Choose Surface ➤ Edit Surface ➤ Project Trim. Trim the body surface with the 
inlet edge.

Select wires to project: Select wire (1) and press ENTER
Select target surfaces: Select surface (2) and press ENTER

1

2
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In the Project to Surface dialog box, specify:

Direction:  Normal to Surface
Output Type: Trim Surface, then OK

Do not reset the DELOBJ variable because you will need to retain pro-
jected wires in the following steps.

The projected wire cut away a portion of body A surface, but the wire was not 
deleted.

8 Freeze layer 20.

Cut out the surface areas on body C where body D and the outlet (to be surfaced 
later) extend onto body C.

NOTE

body surface removed
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To project onto the body C surface

1 Choose View ➤ Model Views ➤ Front. Change the display so that you can 
project wires onto the surface.

2 Choose Surface ➤ Edit Surface ➤ Project Trim. Trim body C with the lower 
curve of the flat surface (1).

Select wires to project: Select wire (1) and press ENTER
Select target surfaces: Select surface (2) and press ENTER

In the Project to Surface dialog box, specify:

Direction: Normal to Surface
Output Type: Trim Surface, then OK

You may have noticed that the Project to Surface dialog box is displayed 
when you select either Surface ➤ Create Wireframe ➤ Project Wire or Surface ➤ 
Edit Surface ➤ Project Trim. Although all dialog box options are available with 
either menu option, the default settings depend on the menu selection. For 
example, for Create Wireframe, the output type defaults to Polyline. In this case, 
you selected Edit Surface, so the default output option is Trim Surface.

1

2

TIP
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Your model should look like this.

3 Use View ➤ Model Views ➤ Right Isometric.

If you prefer to set the viewpoint precisely, use VPOINT to specify coordi-
nates. For example, this viewpoint is -5,-10,3.

4 Choose Surface ➤ Edit Surface ➤ Project Trim. Trim the body B surface with 
the curve that defines the upper edge of the outlet.

Select wires to project: Select wire (1) and press ENTER
Select target surfaces: Select surface (2) and press ENTER

TIP

2

1

3

4



Chapter 13 Surfacing Wireframe Models

386

In the Project to Surface dialog box, specify:

Direction: Normal to Surface
Output Type: Trim Surface, then OK

5 Choose Surface ➤ Edit Surface ➤ Project Trim. Trim body C with the curve 
that defines the lower edge of the outlet.

Select wires to project: Select wire (3) and press ENTER
Select target surfaces: Select surface (4) and press ENTER

In the Project to Surface dialog box, specify:

Direction: Normal to Surface
Output Type: Trim Surface, then OK

6 Set the DELOBJ variable back to 1 so that it is in the default state (to delete 
objects).

Your model should look like this.

7 Use CHPROP to move surfaces A, B, and C to the BODY layer.

Next, you edit the wireframe to join the lines that form the boundary of 
body D. You use the polyline to create a planar surface.
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To create the body D surface

1 Choose Surface ➤ Edit Wireframe ➤ Join. Combine line segments.

In the Join 3D dialog box, specify:

Mode: Automatic
Output: Polyline, then OK
Select start wire: Select the wire (1)
Select wires to join: Select wires (2), (3), and (4)
Select wires to join: Press ENTER
Reverse? Yes/<No>: Press ENTER

2 Choose Surface ➤ Create Surface ➤ Planar. Create a planar surface from the 
joined line.

Plane/Wires/<First corner>: Enter w
Select wires: Select wire (5) and press ENTER

1

2

3

4
5
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Your model should look like this.

3 Use CHPROP to move body D to the BODY layer. Save the file.

The pump body surfaces are complete.

Creating Complex Swept Surfaces
Next, you create the surfaces for the outlet on the side of the pump.

Outlet A is a swept surface that blends dissimilar cross sections.

To create the outlet A surface

1 Thaw layer 40 and make it current, and then freeze all other layers.

2 Change to the Left Isometric view to make lines easier to select.

outlet F
(back side) outlet E

outlet C

outlet A

outlet B

outlet D
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3 Choose Surface ➤ Create Surface ➤ Sweep. Use the three cross sections and 
two rails in a swept surface.

Select cross sections: Select wires (1), (2), and (3)
Select rails: Select wires (4) and (5)

In the Sweep Surface dialog box, specify:

Transition: Scale, then OK

Outlet A should look like this.

4 Use CHPROP to move outlet A to the OUTLET layer.

Next create a ruled surface for outlet B. The difference between this surface 
and the one you just completed is that outlet A is curved in two directions 
and outlet B is curved in one direction and flat in the other.

1

2

3

4

5
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To create the outlet B surface

1 Choose Surface ➤ Create Surface ➤ Rule.

Select first wire: Select wire (1)
Select second wire: Select wire (2)

Outlet B should look like this.

2 Use CHPROP to move outlet B to the OUTLET layer.

For the next surfaces, you create another swept surface and another ruled 
surface.

To create the outlet C and outlet D surfaces

1 To make selections easier, rotate the model to the left with the Desktop View 
icons or set specific coordinates (6, -8, 1) with VPOINT.

1

2
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2 Choose Surface ➤ Create Surface ➤ Sweep. Create outlet C.

Select cross sections: Select wire (1)
Select cross sections: Select the wire (2) and press ENTER
Select rails: Select wire (3)
Select rails: Select wire (4)

In the Sweep Surface dialog box, specify: 

Transition: Scale, then OK

3 Choose View ➤ Model View ➤ Right Isometric.

4 Choose Surface ➤ Create Surface ➤ Rule. Create outlet D.

Select first wire: Select wire (5)
Select second wire: Select wire (6)

Your model should look like this.

4

2

3

5

6

1
3
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5 Use CHPROP to move both of the surfaces to the OUTLET layer.

Next, you join lines to form the boundaries of body D and outlet F. From the 
newly created polyline, you create planar surfaces for the outlet.

To create the outlet E and outlet F surfaces

1 Choose Surface ➤ Edit Wireframe ➤ Join. In the Join3D dialog box, specify:

Mode: Automatic
Output: Polyline, then OK
Select start wire: Select wire (1)
Select wires to join: Select wires (2), (3), and (4) and press ENTER
Reverse? Yes/<No>: Press ENTER to accept the join direction

2 Choose Surface ➤ Create Surface ➤ Planar. Create outlet E surface.

Plane/Wires/<First corner>: Enter w
Select wires: Select wire (1) and press ENTER

3 Choose Surface ➤ Edit Wireframe ➤ Join. Combine lines that form the 
boundary for outlet F.

In the Join 3D dialog box, specify:

Mode: Manual
Output type: Polyline, then OK
Select start wire: Select start wire (5)
Select wire to join: Select wire (6) and press ENTER
Reverse? Yes/<No>: Press ENTER

Use the Manual mode to join lines even if they are far apart. It joins all the 
lines you select in the order you choose them.

3
2

1

4

6
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TIP
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4 Choose Surface ➤ Create Surface ➤ Planar. Create outlet F from the lines you 
just joined.

Plane/Wires/<First corner>: Enter w
Select wires: Select wire (6) and press ENTER

Your model should look like this.

5 Use CHPROP to move the surfaces to the OUTLET layer.

6 Save the file.

Using Projection to Create Surfaces
Next, you use projection to create ruled and planar surfaces for the base of 
the pump.

base A

base B

base C
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To create the base A surface

1 Thaw layer 50 and make it current. Then freeze all other layers.

2 Use ZOOM to enlarge the view.

3 Choose Surface ➤ Create Surface ➤ Rule. Create base A surface.

Select first wire: Select wire (1)
Select second wire: Select wire (2)

The illustration shows the ruled surface fit to the flat areas and corner curves.

4 Use CHPROP to move base A to the BASE layer.

Next, you join the lines needed to create a planar surface on the bottom of 
the pump. Then copy the surface and trim it.

To create the base B and C surfaces

1 Choose Surface ➤ Edit Wireframe ➤ Join. Create a polyline from two wires.

In the Join3D dialog box, specify:

Mode: Automatic
Output: Polyline, then OK
Select start wire: Select wire (1)
Select wires to join: Select wire (2) and press ENTER
Reverse? Yes/<No>: Press ENTER

1

2
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2 Choose Surface ➤ Create Surface ➤ Planar. Create a planar surface on the bot-
tom of the base.

Plane/Wires/<First corner>: Enter w
Select wires: Select wire (1) and press ENTER

The planar surface is created.

3 Copy the last surface.

Select objects: Select surface (1) and press ENTER
<Base point or displacement>/Multiple: Enter end
of: Select point (2)
Second point of displacement: Enter end
of: Select point (3)

4 Use CHPROP to move the bottom surface to the BASE layer.

1

2

1

3
2
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5 Choose Surface ➤ Edit Surface ➤ Project Trim. Project the curve of the body 
onto the top surface of the base.

Select wires to project: Select polyline (1) and press ENTER
Select target surfaces: Select surface (2) and press ENTER

In the Project to Surface dialog box, specify:

Direction: Normal to Surface
Output type: Trim Surface, then OK

Your model should look like this.

6 Use CHPROP to move the surfaces to the BASE layer. Save the file.

Using Advanced Surfacing Techniques
Next, you create the support rib from the surfaces. Using the techniques you 
have already learned, you should be able to surface the support rib from these 
general instructions.

Save the file before you begin working on your own.

1

2
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To create the support rib

1 Thaw layer 60.

2 Create a ruled surface on the left side of the support rib (rib A).

3 Create a ruled surface on the right side of the support rib (rib B).

4 Move the surfaces to the SUPPORT_RIB layer.

5 Create a swept surface for rib C.

6 Move the surface to the SUPPORT_RIB layer.

7 Add the support rib onto the body and base surfaces.

If you need to, follow these specific instructions to create the support rib.

To create the rib A and rib B surfaces

1 Thaw layer 60 and make it current. Then freeze all other layers.

2 Choose Surface ➤ Create Surface ➤ Rule. Create a ruled surface on the left 
side of the support rib.

Select first wire: Select wire (1)
Select second wire: Select wire (2)

3 Choose Surface ➤ Create Surface ➤ Rule. Create a ruled surface on the right 
side of the support rib.

Select first wire: Select wire (3)
Select second wire: Select wire (4)

The surfaces should look like this.

4 Use CHPROP to move the surfaces to the SUPPORT_RIB layer.

rib C

rib B
rib A

1

2

3

4
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To create the rib C surface

1 Choose Surface ➤ Create Surface ➤ Sweep.

Select cross sections: Select wire (1) and (2)
Select cross sections: Press ENTER
Select rails: Select wires (3) and (4)

In the Sweep Surface dialog box, specify:

Transition: Scale, then OK

Your surface should look like this.

2 Move the surface to the SUPPORT_RIB layer.

3 Choose Surface ➤ Edit Wireframe ➤ Join.

In the Join3D dialog box, specify:

Mode: Automatic
Output: Polyline, then OK
Select start wire: Select wires (1), (2), (3), and (4) and then press ENTER
Reverse? Yes/<No>: Press ENTER

The support rib wires are joined and ready to project onto the pump.

1
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To add the support rib

1 Thaw the BODY and BASE layers.

2 Choose Surface ➤ Edit Surface ➤ Project Trim.

Select wires to project: Select wire (1) and press ENTER
Select target surfaces: Select surface (2)
Select target surfaces: Select surface (3) and press ENTER

In the Project to Surface dialog box, specify:

Direction: Normal to Surface
Output: Trim Surface, then OK

The support rib is projected onto the body and the base.

3 Save your file.

3 2
1

body surface removed
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Viewing the Completed Surfaced Model
To view the completed model, freeze all layers except BASE, BODY, INLET, 
OUTLET, SUPPORT_RIB, and TOP.

Use the Extents option of the ZOOM command to view the entire wireframe 
model.


