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Background: 

The ship lines were created by Dr Allen Magnuson in Feb 2005 using Vacanti Prolines LE. The 
data was exported in 2D dxf format, then traced in TurboCad Pro 8.2. Hull is based on the 
proportions of Noah's Ark according to Genesis 6:15.  
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LOFTING TUTORIAL: A ship hull in 3d 

 

To Start  with. . .  

We want to turn 2D ship lines into a 3D CAD model. Start with 3 sets of lines - body, profile and 
plan drawings in dxf format as shown below. These drawings have 60 stations which is a bit 
excessive. This is OK - we will simply ignore some of them, especially in the 'boring' midship 
area. 

Body.dxf 

Profile.dxf 

Plan.dxf 

 

Definit ions 

Station. A cross-section taken across the width and height of the hull. The shape of the hull at 
each station appears in the Body lines drawing. 

Waterline. A cross-section taken as a horizontal plane. The waterline shape appears in the Plan. 

Buttock lines. The vertical longwise plane - the shape is shown in the Profile view.  



dxf. A generalized drawing format used for transporting drawings between different CAD 
programs. There are both 2d and 3d dxf formats, but 2d is very well known. There are 
alternative 3d conversion formats that are more modern and reliable than the 3d dxf. The 
disadvantage of converting to dxf is that the curves are broken into pieces and approximations 
are made. In our case we are simplifying  

 

Checkl ist  

• Ship lines - body, profile and plan in dxf format. 
• Knowledge of the scale. You want to ensure these drawings import into the 3D modeler 

at the right scale. If not you will need to scale them correctly in 3D mode. 
• A 3d CAD program that supports 'lofting' (a 3D shape formed through a series of 2D 

cross sections).  In this tutorial we are using Turbocad v8, but other (more expensive) 
CAD programs could do the job. (Autocad, Solid Works, Solid Edge, Inventor, Rhino, 
etc)   

Remember - Slow and steady - its quicker when you only have to do it once. 
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STEP 1: Set the first dxf in 3d 

 

1. Import the Body l ines 

Turbocad will open the 2d dxf file directly into 3d space. Simply File > Open > {body.dxf}  

Open Design Director (F3 or View/Design Director) shows that Vacanti's dxf generator placed 
every line on a different level. This will be handy later on.    

 

 

2. XYZ orientation  

It's logical to make the X axis 
longitudinal, Z axis vertical, and 
Y axis defined by right hand 
coord system. Like this; 

Since Turbocad starts in the XY 
plane, it is best to begin with 
{Plan.dxf}. (You could force 
something else, but why 
bother?) 

The dxf happens to land on my 
page with the X axis pointing 
towards the stern. That's 
probably a good thing because 
as we increase in X coordinate 
we are working towards higher 



station numbers. This should work OK.  

 

Now spin the thing in 3D (drag with middle button of your 3 button scroll mouse). If you don't 
have a 3 button scroll mouse then... go away!  

Now that you have come back with a new mouse, you'll be happy to know Turbocad's zoom 
works nicely with scroll - it always centers the zoom at the cursor position which turns out to be 
the quickest way to dynamically pan, zoom & spin than I know of - and all with just 1 finger.   

 

 

3. Group and Mirror 

To mirror the thing, you must use SNAP.  TurboCad has a funny button called "No Snap", which 
means you press it to turn snap OFF. Don't press it. You can't anyway - at least not until you 
specify what sort of snapping you want... 

Better make sure you have the Snap Modes toolbar on first.  View > Toolbars... > Check "Snap 
Modes" > OK 

 

We want to snap to the nearest point, so on the Snap Toolbar, press the "Nearest on Graphic" 
icon. (Or whatever you feel is appropriate) 



 

OK, it's mirror time... 

• Make sure you are in top (default view); View > Camera > Top 
• Select all the geometry with a select window. (Select button is the mouse arrow icon). It 

should all turn purple. 
• Group the whole thing so it is easy to work with. Format > Create Group   
• Press "Mirror Copy" button; (Or Edit > Copy Entities > Mirror) 
• Pick two points that represent the mirror line - this can be anywhere on the hull center-

line (zoom up !). You should have the whole hull now 

 

 

4. Check Scale 

We had better check the size of the ship before going too far. We will dimension the overall 
length or some other known dimension. 

• Start in top view (alt+up). Zoom up on the front.  
• Change snap mode to Intersection - it's safer.  
• Press Orthogonal dimension button. (on Drawing Tools toolbar) 
• Click 2 points and read the dimension. The scroll button zoom/pan comes in handy here. 

Well we get 5542.4695 for the length. What are the units?  

Options > Drawing Setup > Space Units.  

It is in inches - so that's 461.8 ft, or 140.8m.  Yes, we have the right scale.    

Station measurement. Measuring from station 1 to station 60, we get 5360.799" (136.164m or 
298 cubits at 18" length). There are actually 59 spacings, so each space is 1/59th, or 90.861" 
(about 7.6 feet). The spacing is important, we will need that 90.861" number. 

 

5. Check posit ion along X axis 

I want to position the hull so that Station 1 is at X=0. To check this, first zoom up on the bow - 
where the first station 1 is. When you try to click the station line, the WHOLE side is lit up.   



 

Ungroup this side. Format > Explode. Now you can select Station 1 line. Oh dear, look at Pos X - 
we are out by 11.6174". The plan lines need to come back to the left by this amount.  

 

Undo to get back to grouped geometry, then select everything. Now we have Pos X = 
2692.0201" (which is the middle). Subtracting the 11.6174 error, leaves 2680.4027". Just type 
this into the Pos X textbox. 

(If you like, you could Explode again and click the Station 1 line to show Pos X = 0)   



 

6 .  Save it  as new drawing 

• Save it with a new name. File > Save As... > "Ship.tcw" or something 
• Spin it to check (Middle button drag) 

 

The nice thing is that Vacanti has given all the lines in appropriate layers and layer names. There 
are 94 layers listed here, the current layer is called "0" and all layers are visible. Click the visible 
icon to see which line is which layer. 

 



 

7 .  Workplanes  

NAME IT. It would be a good idea to label the current (default) XY workplane in Design Director 
(DD). Click on WorkPlanes(0) in DD, then Right Button (RB) in the first table cell > Create New > 
type "plan_lines". No need to change any position and orientation data.  Give it a tick (check) to 
make it active.  

 

WORKPLANE SIZE: To display the workplane, use the menu; Workspace > Display WorkPlane. 
You should see the (red) workplane like the image below. If your workplane is a silly size you 
can zoom to extents first (View > Zoom > Extents) and then fit the workplane to this 
(Workspace > Workplane > Fit To Window).  
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STEP 2: Paste the other dxf's 

 

1. Workplane for Body l ines 

In Design Director (DD), click on WorkPlanes, then Right Button (RB) in table > Create New > 
type "midship". 

Tick (check) it. You will see that the plane is lying flat but we want it upright. To get the 
workplane vertical and facing the right way we have to play with the orientation.  

• Position:  0, 0, 0 (leave as default) 
• X Vector:  0, -1, 0 (horizontal pointing to right when viewing by workplane) 
• Up vector: -1, 0, 0 (the 'up' vector is the plane normal) 

 

Spin it to check. Not very "amidships" is it? It has defaulted to station 0. 

 

 

2. Move Body workplane to midship  

Remember that station spacing? 90.861". We need to move the plane 59/2 spacings in the +X 
direction, which is 2680.4 inches. 

To move the new workplane; In DD, click the Position cell of the "midship" workplane. Enter X of 
2680.4 > OK. (If the plane does not move, sometimes you might set another plane as current, 
then come back and set this one current to refresh it - assume the workplanes are on of course. 
Workspace > Display Workplane)  



Notice that the new workplane does not line up with any station - that's because we have an 
even number of stations. It sits exactly halfway between Station 30 and Station 31. (You can 
check this by going back to Layers in DD, then invisible STA30 or STA31. 

 

 

3. Group the Body.dxf geometry 

To paste Body.dxf onto the new plane; 

• Start a new temporary TC drawing. Start > New... > New from Scratch 
• Open Body.dxf  

 

• This time we want to break the sketch into 2 halves, and group each half separately. 
(You'll see why later). Make sure you get everything on the RHS - use a combination of 
window selects and picks while holding the shift button down. Group this side; Format > 
Create Group 



 

  

• Do the same for LHS. Take care to get them all. (You can turn off the current layer 
visibility in DD to check if you got them all on the RHS... Looks like this;  

 

• Now select the remaining LHS geometry and group it. 
• Turn visibility back on to your current layer (mine was Layer 0) 
• Select both sides and and copy to clipboard. 



 

4. Insert  the Body.dxf l ines 

Back on the Ship.tcw drawing, set the view to the new workplane (in DD click the 3rd column 
"View by Workplane" of "midship"). You will get a very boring scene since you are now looking 
"end on".  

 

Now paste from clipboard.  Spin in 3d to check. 

 

Check if Body lines are centered to the hull center line, measure any mismatch and move it by 
coordinates. Looks pretty good to me - no matter how much I zoom up the sides are aligned. 

Better save it. 

 

5. Make the Prof i le workplane 

In DD, under workplanes > RB > Create New > "profile".  

Orientate the plane; 

• Position: (2680.4, 0, 0) 
• X vector: (1, 0, 0) 
• Up vector: (0, -1, 0) 

Don't forget to refresh to see the new workplane orientation. To check it's position, view from 
top (alt+up arrow) and zoom up to check the edge view of the new workplane lines up with 
centre of the plan lines. 



 

6. Fit  Prof i le.dxf  

• Go get it;  File > Open > Profile.dxf.  
• Group it; Window Select everything > Format > Create Group. 
• Copy it to clipboard; Edit > Copy. 
• Now go back to Ship.tcw, then 'View by Workplane' on "profile". 

To attempt some symmetry, turn off workplane (Workspace > Show workplanes). Then View > 
Zoom> Extents to center the stuff. Now turn workplanes on again. 

• Now paste. Looks reasonable 

 

Still need to check the position carefully. Zoom up shows alignment is OK. 

Finished the dxf setup! SAVE IT 
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STEP 3: Set up loft profiles 

 

1. Right Hand Side 

• First of all, Save it. 
• Now save again as a new name (to keep the old one safe). Like Ship002.tcw 
• Now mirror the Body LHS to the RHS, then erase the old LHS. The fore & aft lines are 

now on top of each other on the RHS. It is easy to do this while still grouped in each half. 
See why we did it now?  

• Now explode everything and you get this mess... 

 

Test the layers. In Design Director (DD), hide a layer - you should see 3 corresponding curves 
disappear, which is really the one curve projected onto the 3 planes - plan, body and profile. 

 

2. Simpli fy 

There are a lot of lines here. If I was me, I'd chuck some. Keep a good accuracy near the busy 
areas of bow and stern, but throw away lots of stuff in the middle. 

Delete station layers to keep only the following; 

• Stations: 
1,2,3,4,5,6,8,10,12,15,18,21,25,30,35,39,42,45,47,49,51,53,55,56,57,58,59,60 

• Waterlines: 2,4,7,10,14,18 
• Buttock lines: 1,2,4,6,8 
• Chine 



 

 

3. Spl ine Dividers 

We are working almost exclusively with station lines, as these will form the section profiles for 
the hull loft. Turbocad is happiest when it has the same number of points for each loft profile 
(station). To help us do this we will sketch some radiating lines on the Body plane (amidships). 
We will use 12 points per section, which means 11 dividing lines radiating from the top centerline 
(Drawn in blue here - directly onto the Body workplane). The radiating lines are concentrated at 
the bilge radius to improve resolution at that spot.    

 



Notice the vertical line set at the bow stem thickness (12th line). This will become the loft inside 
limit - which leaves a gap between LHS and RHS of the hull. The keel and stem will be added 
later as a separate object. 

Pretty isn't it? Trouble is I forgot to tell you to put them on a new layer. Sorry... just kidding. 
CAD isn't this cruel. Now for our next trick.... 

 

4. Whoops.  How to move stuff  to another layer.   

(This could come in handy!) 

• In DD, make a new layer "dividers". BTW It's no fun having the new layer at the bottom 
of a big list, so drag it up near the top. 

• Select the 12 divider lines (Hold down Shift as you pick them. This will flick you back to 
Level "0" - the default level they went on) 

 



 

• While these are selected, simply make the "dividers" layer current. That's it. Hey Presto, 
easy peasy! 

 

 

5. Spl ines setup 

Each station curve (body line) will be a spline. In Turbocad we can set the mathematical 
resolution of spline. The default is 20 points between each control point (node), but we will 
reduce this to make the curves smoother. (Bit silly to have station control points so close 
together if the stations-to-station distance is so much larger).  

Use the standard Properties Dialogue to get at the object's Properties (Like you do for everything 
else in TC). There are lots of ways to get to it; 

From the Main Menu choose Format| Properties. OR 
Right-click anywhere in the drawing and select Properties from the Local Menu. OR 
Select the Properties icon in the lower left corner of the screen on the Inspector Bar. OR 
Set some Properties directly using the Properties toolbar. OR 
Open the Properties Palette at the right of the screen. OR 
When the Select tool is active, double click the object.  

• Anyway, RB on blank screen area > Properties... > Curve > Set control points to 5 
(default was 20). Set curve type to Spline. OK 

• Oh, and make a new layer called "splines_fore". We'll draw the splines onto this later.  
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STEP 4: Loft test 

 

1. Station Workplane 

First we need a workplane (WP) at station 1. It will be parallel to the midship plane. 

• In DD, workplane mode > set "midship" as current 
• RB in table > Create New > "STA1" 
• Set the new workplane STA1 as current. Still looks like the midship plane. 
• Modify the Position; X was 2.68040000000000010000e+003 which is 2680.4, now 

change to 0. So position is now (x,y,z)= (0,0,0) 
• Refresh the WP (set another WP current, then current back again) 
• Spin it to test placement 

 

 

2. Draw a loft  prof i le spl ine 

• Set DD Workplane: View by " STA1".  Set DD Layer: "splines_fore" 
• Pick the Spline tool. Set the color to red (or something that stands out) 
• Using snap (intersection is OK) to snap the 12 points. Make sure the spline starts at the 

lower inside on the limit line - and nodes are in order up to the top/outside.  
• Edit the spline to nudge it - Click on the (red) spline > RB > Edit Node. This should show 

the 12 dots (nodes). You zoom up on the line and nudge it closer to the black dxf line by 
shifting a node. This is a bit of an art, but you get the hang of it. Try to keep the nodes 
on their radiating line which helps the smoothness of the final loft. Best to use the snap 
mode "Nearest on Graphic" to hold the node on the divider line, or end lines. Don't get 
too fussy - if you zoom up too much you'll be there forever.  



 

Note. The dxf curve is a bit rough at places isn't it? Don't worry, let the spline take the 'average' 
shape of the curve. 

 

3. Do the f irst 5 spl ines. . .  

Repeat steps 5 & 6 to draw all the splines for the hull. I suggest you do about 5 and then test it 
out... 

The X position data for all stations; 

Sta  X fore  Sta X aft  
1  0  35  3089.274  
2  90.861  39  3452.718  
3  181.722  42  3725.301  
4  272.583  45  3997.884  
5  363.444  47  4179.606  
6  454.305  49  4361.328  
8  636.027  51  4543.050  
10  817.749  53  4724.772  
12  999.471  55  4906.494  
15  1272.054  56  4997.355  
18  1544.637  57  5088.216  
21  1817.220  58  5179.077  
25  2180.664  59  5269.938  
30  2634.969  60  5360.799  

Just  do the first 5 for the moment...   

 
 



 

4. A test loft  

Complete the first 5 station splines.   

 

Test the layers. In Design Director (DD), hide a layer - you should see 3 corresponding curves 
disappear, which is really the one curve projected onto Here is STA2, where you need to cheat a 
bit to get the spline to match the dxf curve. The radiating lines are just a guide, so disobey them 
if necessary.  

 

5. Test Loft .  

• Make a new layer; "loft" and make it the current layer. 
• Spin the model so that you can easily select the (red) splines. (Like image in step 4 

above) 
• Select each spline, in order from STA1 to STA5 . Remember to hold shift key during 

multi-select. 
• RB > finish 

 



Note: Hooray - some 3D geometry!  Notice how I hid the waterlines and every station aft (layers 
set invisible) - to keep it simple.  

• Better check the loft is actually on the "loft" layer. If not, do the move trick. (Select the 
loft, then make the desired layer current) 

• Save it.  (BTW. I am up to Ship008.tcw now. What are you up to?)  

You see, every time I do something a bit serious, I save the file with an incremented name (Save As...). That way if 
something happens I can go back to that previous step. I have had one TC sickness so far in this session - the X position of 
the new workplanes wouldn't change in DD, so I closed and restarted TC and fixed it. I'm using TC 8.2 pro - seems to work 
OK on my AMD 2.8, 512RAM, and it cost me AUD$70 unopened from a Ebay retailer.    

 

6. Fun with rendering 

Well, if you got this far you deserve a fun break.  

Lighting. First thing is to get rid of the squillions of lights in default settings. Keep it simple - 
just start with the ambient light. 

• In DD pick Lights category > delete them all. 
• In DD table > RB > Create new "ambient"  
• Now RB on "ambient" > Edit Properties > Light 
• Choose ambient type. Power = 1000W should do - and pick a color. Make sure it is ON ! 

 

Textures.  

Go back to properties. (RB on the loft itself) > General > Pick "Wood Floor" and "Pine 
Floorboards" > OK 

Now view this with the Quality Render button (teacup) - or View/Camera/Quality render.  

Hmmm. Sometimes it doesn't happen - try toggling clicking the light visiblity icon (the blue eyes 
and nose stands for visibility) 



 

Fun starts about here... 
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STEP 5: Loft Better 

 

1. Not a pretty sight 

The hull looks nice doesn't it? - Well, not really. 

Delete the loft and add the bow profile (drawn onto the "profile" workplane). Now redo the loft. 

By the time you complete the bow by adding the front profile the loft is looking a little strange.  
You see, the problem is the division lines do not 'flow' with the curvature very well. The best loft 
is one where the nodes line up to be almost  perpendicular to the loft profiles. In other words, we 
want the loft to be form a 'grid' of approximate rectangles instead of parallelograms. 

 

Think of the loft forming straight lines between loft profiles. If the straight lines span the loft 
profiles at a steep angle the resulting loft will not be smooth. Change the texture to 'grid'; 

• Select loft > RB > Properties > 3D > Category = Miscellaneous, Material = Grid > Edit 
Material... > Wrapping: Y plane, Scale=80 > OK > OK 

Now do Quality Render. Spin and zoom to accentuate the surface irregularities. 

 

We can play with the ACIS settings to improve this; (ACIS is the 3D geometry engine, same one 
as AutoCAD) 



• Options > ACIS... > Quality 

But there is a limit to how much improvement we can get by increasing smoothness tolerances 
(and we are trading accuracy of course) 

 

 

2. A better node arrangement 

We want to fit the nodes along each Body to give a better loft. Try this modified set of division 
lines for setting the profile nodes more perpendicular to the loft. The second image shows the 
resulting loft, with the (purple) loft lines indicating an improved 'flow' along the hull. The 3rd 
image shows the much improved surface when viewed in Quality Render with "Grid" material.  

       

 



 

3. Halfway along.. .  

The complete set of station X axis positions - measured from Station 1. 

Sta  X fore  Sta X aft  
1  0  35  3089.274  
2  90.861  39  3452.718  
3  181.722  42  3725.301  
4  272.583  45  3997.884  
5  363.444  47  4179.606  
6  454.305  49  4361.328  
8  636.027  51  4543.05  
10  817.749  53  4724.772  
12  999.471  55  4906.494  
15  1272.054  56  4997.355  
18  1544.637  57  5088.216  
21  1817.22  58  5179.077  
25  2180.664  59  5269.938  
30  2634.969  60  5360.799  

The loft to midsection is shown below. Keep checking the loft after several profiles are done to 
check for any faults. If the loft suddenly splits into a large number of lines then you need to trace 
the faulty loft profile (Test by slipping profiles in temporary lofts until the problem profile can be 
isolated).  

 

 
T i m  L o v e t t  ©  2 0 0 5  |  A l l  R i g h t s  R e s e r v e d |  h t t p : / / w w w . w o r l d w i d e f l o o d . c o m   

http://www.worldwideflood.com/


STEP 6: Shelling 

 

1. Shel l  test  

The loft represents the planking of the hull. More specifically, the INSIDE surface (where 
planking meets the frames). To give the loft some thickness, the Shell command is used. Here's 
how; 

• Modify > Shell Solid 
• Select the loft  
• In the Shell settings menu (bottom of TC screen), set the wall thickness to 12 inches, and 

pick "Shell Outwards". Then Finish. 

 

Error Message? 

 



Try shelling the other way (Shell Inside). In my case it worked this time, and the hull looks like 
this... (using Hidden Line render) 

 

Wait a minute. Let's check the bow elevation view to see which way we really shelled... 

 

Yes, the Shelled Loft (green) is definitely outside the loft profiles (red). This means the shell is 
actually outward. It is not always easy fot a computer to work out what is the inside and the 
outside of an object - in this case it got it round the wrong way.  



 

2. Repair  bow detai ls  

The fact that one of the lofts didn't work is not good.  It is caused by poor loft geometry at the 
base of the bow. The transition from Station 1 to the bottom of the bow profile is awkward and 
must be tweaked to give a smooth loft. By making a thicker shell you can see what is going on. 
Here it is again at 24 inches thick... 

 

This means the loft was turning inwards as it approached the stem - so station 1 must be 
brought inwards, or the bow pushed outwards.  

• Tweak station 1 and/or bow profile 
• Rebuild the loft (the first 4 or 5 profiles should be an adequate test 
• Test the shell 

Repeat above steps until the loft will shell correctly. The lowest portion of the stem is difficult to 
smooth out. Another work-around is to bring this detail inboard a little to ensure it is completely 
hidden inside the stem post (when it is added later).  
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STEP 7: Full Length 

 

1. Aft  dividers for spl ine nodes. . .  

The aft body lines have been mirrored on top of the fore lines. The best way to avoid confusion is 
to hide the fore layers and make only the aft layers visible. 

 

The fore line dividers (blue) are not very well suited to the aft hull shape. We need to draw a 
new set of node dividers. In the fore section we ignored the keel, so we continue this trend and 
ignore the skeg also. We want the node divider lines (tan colored) to still give 12 points on each 
body profile (black), so the inner dividers need to be raised as shown below. 

 



Whoops. I had Workplane 35 active while I was drawing, instead of Workplane "midship" like the 
rest of the body lines.  

To swap stuff to a different workplane is very easy; (handy hint) 

• Select the stuff > Set the desired workplane active "midship" > Format/Place on 
workplane 

   Swap to workplane "midship"...   

 

2. The Aft  prof i les 

Now continue to draw station splines for the rest of the hull. Here is the complete station data; 

Sta  X fore  Sta X aft  
1  0  35  3089.274  
2  90.861  39  3452.718  
3  181.722  42  3725.301  
4  272.583  45  3997.884  
5  363.444  47  4179.606  
6  454.305  49  4361.328  
8  636.027  51  4543.05  
10  817.749  53  4724.772  
12  999.471  55  4906.494  
15  1272.054  56  4997.355  
18  1544.637  57  5088.216  
21  1817.22  58  5179.077  
25  2180.664  59  5269.938  
30  2634.969  60  5360.799  

Now carry on, drawing the loft profile splines... 



 

There are similar issues with the lower area of the stem at the stern - problems with lofting 
geometry in the transition from the transverse profiles to the stem profile. Best to do some 
isolated lofting and shelling until you get this geometry working. It seems a bit easier than the 
bow, which could be due to the near hollow in the bow entry. 

The final profiles ready to loft... 

 

Do the loft... Is this a problem? NO, it's just the Turbocad wireframe taking a shortcut. Maybe 
hide a few bits - like the profiles etc. Good idea to puit the loft on a new layer too. Even better 
idea - save it! (I'm up to "ship16.tcw" now...) 

 

Anyway, if you render to wireframe you will see correct geometry... 

 



 

3 .  Shel l  and check 

TC decided that an "shell inwards" actually goes outwards here. Anyway, the shell went ok... 

 

If TC can't work out inside and outside, we'd better check... With some loft lines displayed, zoom 
up... 

 

The test of a robust shell is to see how thick the wall can be before it fails to shell. 
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STEP 8: Keel, Mirror & Render 

 

1. Mirror test 

Mirror the half hull. 

• Make layer on the profile workplane visible (the geometry will be used as a mirror plane) 
• Set a horizontal workplane (waterplane_0). This should be seen as a top view  
• Select the shelled loft 
• Mirror command (Edit / Copy Entities / Mirror) 
• "Select the first point of the mirror line"... Pick the points on the profile workplane using 

the "Nearest on Graphic" snap. 

 

Works OK.  

Delete this mirrored half again. We will finish it off before doing the final mirror. 

 

2. Keel  and Stem 

A simple bit of 3D this time - a plain old sketch followed by a Normal Protrude. 

• Set the center 'profile' workplane.  
• Draw an outline for the keel and stem as a continuous loop.  

 

• If the outline is made of several lines, join it into a polyline. (Modify / Join Polyline) 
• Now protrude this by 20 inches INTO the existing shelled loft. 
• Check that the keel hides any boundary irregularities in the shell. There is something at 

the stern that need's hiding... 



 

 

3. Forecastle by boolean cut   

Again using the central profile workplane, sketch the shape of the weather deck (roof), using the 
level 0 profile as a template. If using a spline curve to create the geometry, remember to "close" 
the curve, otherwise you get a fence instead of a solid. 

• Draw the cut-away shape onto the profile workplane. 

 

• Extrude this curve out 500 inches (so it extends beyond the side of the hull). This image 
is wireframe rendered... 

 

• Do a boolean subtraction. (First you pick the one to KEEP, then the subtractor... So pick 
hull then cutout). Should get this... 



 

• Now do a mirror to see how it looks... (Group the stem and hull together first, so the keel 
is mirrored) 

 

 

4 .  Some Lights and Materials  

Add a quick material. 

Select BOTH hull sides, then RB > Properties > 3D > Edit Material... >  

In Material Properties, select Pine Floorboard, Mapping by X plane > OK etc > Quality Render 

 

Now add a different material to the stem. I used Birch.  

Settings used in the following image; 

• Camera Properties: Perspective = 50 degrees, rendering full 
• Material Properties: Hull = Pine floorboards, mapping auto, plank length 100 width 8 etc 



 

• Lighting: Reduce the ambient from 1000W to 500W. Then add a directional light, (dx=0, 
dy=1, dz=-1), colored light pink (wood is getting a bit too yellow)  

 

Well, there you go. Obviously the planks are oversize, but this allows me to keep the images 
small. Could reduce the ambient a bit more, or darken the wood perhaps. Plenty of graphical 
things to try...  

It would be nice if TC could work out how to plank a ship hull, but this is asking a bit much. To 
be quite honest, planking such a blunt stern is not easy anyway.  

If you think this planking looks like an eggshell, you are pretty close.  Eggshells are 0.36mm 
over 40mm diameter (Coucke et al) or diameter just over 100t, at 12 inches the Ark beam is 
75t. Pretty close to an eggshell. 

http://www.isma_isaac.be/publications/PMA_MOD_publications/ISMA23/p1497p1502.pdf
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